[Classic] No sound when compiling any program

General

exocet

3 months ago

I'm having a weird issue and couldn't find anyone reporting something similar in the past.

When I compile sketches on my PC and open them in Simbuino, they work normally with sound, but when played on the Gamebuino, there's no sound at all. I tried with a very simple program that just plays a sound, I tried to recompile existing games or demos - same result: I'm never able to get any sound to play on the Gamebuino. There's nothing wrong with my Gamebuino as it plays sounds on startup and anything that I don't compile myself (ie HEX files from the internet) is fine and plays sounds as expected.  

I've set #define NUM_CHANNELS 4 in the Library settings file. 

I've updated LOADER and SETTINGS to the latest version. Settings are the default ones.

Any help welcome!


Sorunome

NEW 3 months ago

I assume you also un-muted in the title screen? (hitting B)

exocet

3 months ago

Still weird that only the games I compiled myself appear to be on mute by default...

exocet

NEW 3 months ago

No, I didn't and it appears it might have just been because of that. 

Thanks a lot anyway, I was getting very confused. 

exocet

NEW 3 months ago

Sorunome Sorunome

Still weird that only the games I compiled myself appear to be on mute by default...

Aurélien Rodot

3 months ago

I might be because we changed how the volume is handled. The volume used to go from 0 to 3 and now it's from 0 to 8. To solve this you can compile the SETTINGS.HEX yourself, then adjust the default volume and save it. Tell me if that works :)

Aurélien Rodot

NEW 3 months ago

exocet exocet

I might be because we changed how the volume is handled. The volume used to go from 0 to 3 and now it's from 0 to 8. To solve this you can compile the SETTINGS.HEX yourself, then adjust the default volume and save it. Tell me if that works :)

exocet

3 months ago

Thanks, recompiling SETTINGS seems to have done the trick, my programs run by default at full volume now. 

(For anyone wanting to do the same, the source code for Settings can be found here: https://github.com/Rodot/Gamebuino/archive/master.zip)

erico

NEW 3 months ago

Yep, I have noticed that too on the FIREBUINO game made by another community member.
I have that mute problem while he doesn´t.

exocet

NEW 3 months ago

Aurélien Rodot Aurélien Rodot

Thanks, recompiling SETTINGS seems to have done the trick, my programs run by default at full volume now. 

(For anyone wanting to do the same, the source code for Settings can be found here: https://github.com/Rodot/Gamebuino/archive/master.zip)

You must be logged in in order to post a message on the forum

Log in